fix dependency order for sstrip
[lede.git] / obsolete-buildroot / make / openwrt.mk
index b8c2c9636e7ee018616f62d0ce5599089bb67d49..38fa9587588a039f1a6a669c557e26d1ded0438a 100644 (file)
@@ -202,8 +202,7 @@ openwrt-rootprep:
 
 ######################################################################
 
-openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
-#      -find $(TARGET_DIR) -type f -perm +111 -exec $(STAGING_DIR)/bin/sstrip {} \;
+openwrt-prune: openwrt-base $(STAGING_DIR)/bin/sstrip
        # remove unneeded uClibc libs
        rm -rf $(TARGET_DIR)/lib/libthread_db*
        rm -rf $(TARGET_DIR)/lib/libpthread*
@@ -214,6 +213,7 @@ openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
        rm -f $(TARGET_DIR)/usr/sbin/iptables-save
        rm -f $(TARGET_DIR)/usr/sbin/iptables-restore
        rm -f $(TARGET_DIR)/usr/sbin/ip6tables
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
 
 ######################################################################