2013-05-23 |
Michael Gottesman | Updated the comments of APInt.h to match the llvm style... |
blob | commitdiff | raw |
2013-02-27 |
Aaron Ballman | Switching -1ULL to UINT64_MAX to fix MSVC warnings... |
blob | commitdiff | raw | diff to current |
2013-02-20 |
Benjamin Kramer | Move the SplatByte helper to APInt and generalize it... |
blob | commitdiff | raw | diff to current |
2013-02-20 |
Jakub Staszak | Move part of APInt implementation from header to cpp... |
blob | commitdiff | raw | diff to current |
2013-02-07 |
Meador Inge | ADT: Correct APInt::getActiveWords for zero values |
blob | commitdiff | raw | diff to current |
2013-01-10 |
Jakub Staszak | Fix include guards so they exactly match file names. |
blob | commitdiff | raw | diff to current |
2012-11-30 |
Chandler Carruth | Switch LLVM_USE_RVALUE_REFERENCES to LLVM_HAS_RVALUE_RE... |
blob | commitdiff | raw | diff to current |
2012-10-31 |
Rafael Espindola | Add extra declarations of hash_value needed to build... |
blob | commitdiff | raw | diff to current |
2012-10-26 |
Derek Schuff | Stop APInt::shl from generating llvm.trap |
blob | commitdiff | raw | diff to current |
2012-09-13 |
Dmitri Gribenko | Fix Doxygen issues: |
blob | commitdiff | raw | diff to current |
2012-08-23 |
Dmitri Gribenko | Fix a bunch of -Wdocumentation warnings. |
blob | commitdiff | raw | diff to current |
2012-07-29 |
Benjamin Kramer | APInt: Simplify code. |
blob | commitdiff | raw | diff to current |
2012-07-18 |
Bill Wendling | Remove tabs. |
blob | commitdiff | raw | diff to current |
2012-07-15 |
Eric Christopher | Move IsSameValue from clang's ASTImporter to be methods... |
blob | commitdiff | raw | diff to current |
2012-06-02 |
Benjamin Kramer | Add move semantics to APInt. |
blob | commitdiff | raw | diff to current |
2012-05-22 |
Nuno Lopes | fix the quotient returned by sdivrem() for the case... |
blob | commitdiff | raw | diff to current |
2012-03-14 |
Benjamin Kramer | Move APInt::operator[] inline. |
blob | commitdiff | raw | diff to current |
2012-03-14 |
Benjamin Kramer | Move APInt::operator! inline, it's small and fuses... |
blob | commitdiff | raw | diff to current |
2012-03-04 |
Chandler Carruth | Replace the hashing functions on APInt and APFloat... |
blob | commitdiff | raw | diff to current |
2012-01-27 |
Rafael Espindola | Add r149110 back with a fix for when the vector and... |
blob | commitdiff | raw | diff to current |
2011-11-28 |
Benjamin Kramer | Handle more cases in APInt::getLowBitsSet's fast path. |
blob | commitdiff | raw | diff to current |
2011-09-14 |
Douglas Gregor | Add APInt support for converting to/from hexatridecimal... |
blob | commitdiff | raw | diff to current |
2011-07-18 |
Jeffrey Yasskin | Add APInt(numBits, ArrayRef<uint64_t> bigVal) construct... |
blob | commitdiff | raw | diff to current |
2011-06-15 |
Ted Kremenek | add option for literal formatting to APInt::toString() |
blob | commitdiff | raw | diff to current |
2011-03-27 |
Frits van Bommel | Constant folding support for calls to umul.with.overflo... |
blob | commitdiff | raw | diff to current |
2011-03-17 |
Benjamin Kramer | Add an argument to APInt's magic udiv calculation to... |
blob | commitdiff | raw | diff to current |
2011-02-24 |
Cameron Zwarich | Add a getNumSignBits() method to APInt. |
blob | commitdiff | raw | diff to current |
2011-02-13 |
Chris Lattner | add a helper method. |
blob | commitdiff | raw | diff to current |
2010-12-07 |
Jay Foad | PR5207: Change APInt methods trunc(), sext(), zext... |
blob | commitdiff | raw | diff to current |
2010-12-04 |
Benjamin Kramer | APInt: microoptimize a few methods. |
blob | commitdiff | raw | diff to current |
2010-12-04 |
Benjamin Kramer | Simplify APInt::getAllOnesValue. |
blob | commitdiff | raw | diff to current |
2010-12-01 |
Jay Foad | PR5207: Rename overloaded APInt methods set(), clear... |
blob | commitdiff | raw | diff to current |
2010-11-30 |
Jay Foad | PR5207: Make APInt::set(), APInt::clear() and APInt... |
blob | commitdiff | raw | diff to current |
2010-11-28 |
Jay Foad | PR5207: remove unused methods APInt::Emit() and APInt... |
blob | commitdiff | raw | diff to current |
2010-11-28 |
Jay Foad | PR5207: change APInt::doubleToBits() and APInt::floatTo... |
blob | commitdiff | raw | diff to current |
2010-11-03 |
Dan Gohman | Factor code out of APInt to form a isUIntN helper function. |
blob | commitdiff | raw | diff to current |
2010-10-14 |
Chris Lattner | add uadd_ov/usub_ov to apint, consolidate constant... |
blob | commitdiff | raw | diff to current |
2010-10-13 |
Chris Lattner | missed a line :( |
blob | commitdiff | raw | diff to current |
2010-10-13 |
Chris Lattner | constify these methods. |
blob | commitdiff | raw | diff to current |
2010-10-13 |
Chris Lattner | add a few operations for signed operations that also |
blob | commitdiff | raw | diff to current |
2010-08-13 |
Benjamin Kramer | Use getAllOnesValue, saves a copy and looks better. |
blob | commitdiff | raw | diff to current |
2010-07-14 |
Benjamin Kramer | Don't pass StringRef by reference. |
blob | commitdiff | raw | diff to current |
2010-04-08 |
Dan Gohman | Add variants of ult, ule, etc. which take a uint64_t... |
blob | commitdiff | raw | diff to current |
2010-02-28 |
John McCall | Add an override to StringRef::getAsInteger which parses... |
blob | commitdiff | raw | diff to current |
2010-02-28 |
John McCall | Teach APFloat how to create both QNaNs and SNaNs and... |
blob | commitdiff | raw | diff to current |
2009-10-13 |
Dan Gohman | Add a ceilLogBase2 function to APInt. |
blob | commitdiff | raw | diff to current |
2009-08-23 |
Chris Lattner | remove the dead std::ostream APInt inserter |
blob | commitdiff | raw | diff to current |
2009-08-13 |
Daniel Dunbar | Convert APint::{fromString,APInt,getBitsNeeded} to... |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Dan Gohman | Reapply 74494, this time removing the conflicting defin... |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Bill Wendling | Temporarily revert r74494. It was causing failures... |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Dan Gohman | Define an operator<< for APInt to be used with std... |
blob | commitdiff | raw | diff to current |
2009-04-30 |
Jay Foad | Move helper functions for optimizing division by consta... |
blob | commitdiff | raw | diff to current |
2009-04-13 |
Douglas Gregor | Add a static APInt::getNumWords |
blob | commitdiff | raw | diff to current |
2009-04-01 |
Dan Gohman | Use CHAR_BIT instead of hard-coding 8 in several places... |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Misha Brukman | Fixed lint errors: |
blob | commitdiff | raw | diff to current |
2009-02-09 |
Bill Wendling | These function return 'void'. Don't have 'return' retur... |
blob | commitdiff | raw | diff to current |
2009-01-20 |
Chris Lattner | eliminate use of uint32_t to improve compatibility... |
blob | commitdiff | raw | diff to current |
2009-01-09 |
Misha Brukman | Removed trailing whitespace. |
blob | commitdiff | raw | diff to current |
2008-12-02 |
Chris Lattner | Fix isIntN to work with APInts > 64 bits. This method... |
blob | commitdiff | raw | diff to current |
2008-12-01 |
Eli Friedman | Fix bogus assertion using getSExtValue for legitimate... |
blob | commitdiff | raw | diff to current |
2008-10-11 |
Chris Lattner | random cleanup |
blob | commitdiff | raw | diff to current |
2008-08-23 |
Chris Lattner | Switch the asmprinter (.ll) and all the stuff it requir... |
blob | commitdiff | raw | diff to current |
2008-08-21 |
Chris Lattner | remove redundant include |
blob | commitdiff | raw | diff to current |
2008-08-21 |
Chris Lattner | Fix the build with gcc 4.3 as the host, patch by Zhongx... |
blob | commitdiff | raw | diff to current |
2008-08-21 |
Nick Lewycky | Fix build on GCC 4.3. |
blob | commitdiff | raw | diff to current |
2008-08-20 |
Chris Lattner | Move the fast-path (<=i64) cases of various APInt metho... |
blob | commitdiff | raw | diff to current |
2008-08-17 |
Chris Lattner | Rework the routines that convert AP[S]Int into a string... |
blob | commitdiff | raw | diff to current |
2008-08-17 |
Chris Lattner | remove a dead APInt ctor. |
blob | commitdiff | raw | diff to current |
2008-07-10 |
Duncan Sands | Correct a comment. |
blob | commitdiff | raw | diff to current |
2008-06-23 |
Wojciech Matyjewicz | First step to fix PR2088. Implement routine to compute the |
blob | commitdiff | raw | diff to current |
2008-06-09 |
Duncan Sands | Remove some DAG combiner assumptions about sizes |
blob | commitdiff | raw | diff to current |
2008-05-30 |
Dan Gohman | Fix an error in the comment for APInt::getMinSignedBits. |
blob | commitdiff | raw | diff to current |
2008-05-02 |
Evan Cheng | Suppress -Wshorten-64-to-32 warnings for 64-bit hosts. |
blob | commitdiff | raw | diff to current |
2008-02-29 |
Dan Gohman | Add support to APInt for shift and rotate operations... |
blob | commitdiff | raw | diff to current |
2008-02-26 |
Bill Wendling | Detabify |
blob | commitdiff | raw | diff to current |
2008-02-20 |
Dan Gohman | Remove inline keywords from in-class function definitio... |
blob | commitdiff | raw | diff to current |
2008-02-20 |
Dan Gohman | Add an intersects method to APInt, to capture a common... |
blob | commitdiff | raw | diff to current |
2008-02-13 |
Dan Gohman | Fix a typo in a comment. |
blob | commitdiff | raw | diff to current |
2008-02-13 |
Dan Gohman | Rename APInt's isPositive to isNonNegative, to reflect... |
blob | commitdiff | raw | diff to current |
2008-02-13 |
Dan Gohman | Add countTrailingOnes member functions to APInt. |
blob | commitdiff | raw | diff to current |
2008-02-13 |
Dan Gohman | Fix a typo in a comment. |
blob | commitdiff | raw | diff to current |
2008-02-12 |
Dan Gohman | Change APInt::getBitsSet to accept a "half-open" range... |
blob | commitdiff | raw | diff to current |
2008-02-11 |
Dan Gohman | Correct the order of the arguments in the examples... |
blob | commitdiff | raw | diff to current |
2008-02-08 |
Dan Gohman | Add an isSignedIntN, like isIntN but for signed integer... |
blob | commitdiff | raw | diff to current |
2008-01-19 |
Ted Kremenek | Changed argument name for 'Profile' method to potential... |
blob | commitdiff | raw | diff to current |
2008-01-19 |
Ted Kremenek | Added FoldingSet style 'profiling' support for APInt. |
blob | commitdiff | raw | diff to current |
2007-12-29 |
Chris Lattner | Don't attribute in file headers anymore. See llvmdev... |
blob | commitdiff | raw | diff to current |
2007-12-08 |
Chris Lattner | eliminate dependency on Bitcode headers. |
blob | commitdiff | raw | diff to current |
2007-11-23 |
Chris Lattner | Fix PR1816, by correcting the broken definition of... |
blob | commitdiff | raw | diff to current |
2007-11-07 |
Ted Kremenek | Fixed default ctor for APInt to properly initialize... |
blob | commitdiff | raw | diff to current |
2007-10-26 |
Ted Kremenek | Added serialization support for APInt. |
blob | commitdiff | raw | diff to current |
2007-10-26 |
Ted Kremenek | Fixed incorrect "path name" in preamble (comment) of... |
blob | commitdiff | raw | diff to current |
2007-10-08 |
Neil Booth | Add a new function tcExtract for extracting a bignum... |
blob | commitdiff | raw | diff to current |
2007-10-06 |
Neil Booth | Generalize tcFullMultiply so that the operands can... |
blob | commitdiff | raw | diff to current |
2007-09-21 |
Dale Johannesen | Change APFloat::convertFromInteger to take the incoming |
blob | commitdiff | raw | diff to current |
2007-09-17 |
Devang Patel | Do not hide APInt::dump() inside #ifndef NDEBUG. |
blob | commitdiff | raw | diff to current |
2007-09-14 |
Dale Johannesen | Remove the assumption that FP's are either float or |
blob | commitdiff | raw | diff to current |
2007-08-29 |
Chris Lattner | getMinSignedBits needs to take into consider the sign... |
blob | commitdiff | raw | diff to current |
2007-08-23 |
Chris Lattner | rename APInt::toString -> toStringUnsigned for symmetry... |
blob | commitdiff | raw | diff to current |
2007-08-20 |
Chris Lattner | initial checkin of Neil's APFloat work. |
blob | commitdiff | raw | diff to current |
next |