2011-04-15 |
Chris Lattner | Fix a ton of comment typos found by codespell. Patch by |
blob | commitdiff | raw |
2011-03-01 |
Jim Grosbach | Generalize the register matching code in DAGISel a... |
blob | commitdiff | raw | diff to current |
2010-12-24 |
Andrew Trick | Various bits of framework needed for precise machine... |
blob | commitdiff | raw | diff to current |
2010-12-24 |
Andrew Trick | whitespace |
blob | commitdiff | raw | diff to current |
2010-12-23 |
Chris Lattner | flags -> glue for selectiondag |
blob | commitdiff | raw | diff to current |
2010-12-23 |
Chris Lattner | sdisel flag -> glue. |
blob | commitdiff | raw | diff to current |
2010-10-25 |
Devang Patel | Simplify. |
blob | commitdiff | raw | diff to current |
2010-10-25 |
Devang Patel | Update SelectBasicBlock signature. This should have... |
blob | commitdiff | raw | diff to current |
2010-10-11 |
Chris Lattner | tweak comment. |
blob | commitdiff | raw | diff to current |
2010-09-21 |
Chris Lattner | Rework passing parent pointers into complexpatterns... |
blob | commitdiff | raw | diff to current |
2010-09-21 |
Chris Lattner | just like they can opt into getting the root of the... |
blob | commitdiff | raw | diff to current |
2010-09-05 |
Chris Lattner | implement rdar://6653118 - fastisel should fold loads... |
blob | commitdiff | raw | diff to current |
2010-07-10 |
Dan Gohman | Reapply bottom-up fast-isel, with several fixes for... |
blob | commitdiff | raw | diff to current |
2010-07-09 |
Bob Wilson | --- Reverse-merging r107947 into '.': |
blob | commitdiff | raw | diff to current |
2010-07-09 |
Dan Gohman | Re-apply bottom-up fast-isel, with fixes. Be very caref... |
blob | commitdiff | raw | diff to current |
2010-07-08 |
Dan Gohman | Revert 107840 107839 107813 107804 107800 107797 107791. |
blob | commitdiff | raw | diff to current |
2010-07-07 |
Dan Gohman | Give FunctionLoweringInfo an MBB member, avoiding the... |
blob | commitdiff | raw | diff to current |
2010-07-06 |
Dan Gohman | CanLowerReturn doesn't need a SelectionDAG; it just... |
blob | commitdiff | raw | diff to current |
2010-06-24 |
Dan Gohman | Reapply r106634, now that the bug it exposed is fixed. |
blob | commitdiff | raw | diff to current |
2010-06-23 |
Daniel Dunbar | Revert r106263, "Fold the ShrinkDemandedOps pass into... |
blob | commitdiff | raw | diff to current |
2010-06-18 |
Dan Gohman | Fold the ShrinkDemandedOps pass into the regular DAGCom... |
blob | commitdiff | raw | diff to current |
2010-04-22 |
Dan Gohman | Move HandlePHINodesInSuccessorBlocks functions out... |
blob | commitdiff | raw | diff to current |
2010-04-21 |
Dan Gohman | Add more const qualifiers on TargetMachine and friends. |
blob | commitdiff | raw | diff to current |
2010-04-20 |
Dan Gohman | Reapply the removal of SelectionDAGISel's BB, with... |
blob | commitdiff | raw | diff to current |
2010-04-19 |
Dan Gohman | Revert 101825, which is causing trouble. |
blob | commitdiff | raw | diff to current |
2010-04-19 |
Dan Gohman | Eliminate SelectionDAGISel's "current block" member... |
blob | commitdiff | raw | diff to current |
2010-04-17 |
Dan Gohman | Use const qualifiers with TargetLowering. This eliminat... |
blob | commitdiff | raw | diff to current |
2010-04-15 |
Dan Gohman | Add const qualifiers to CodeGen's use of LLVM IR constr... |
blob | commitdiff | raw | diff to current |
2010-04-14 |
Dan Gohman | Delete unneeeded arguments. |
blob | commitdiff | raw | diff to current |
2010-04-14 |
Dan Gohman | Delete unused arguments. |
blob | commitdiff | raw | diff to current |
2010-04-14 |
Dan Gohman | Factor out EH landing pad code into a separate function... |
blob | commitdiff | raw | diff to current |
2010-04-14 |
Dan Gohman | Delete an unused function. |
blob | commitdiff | raw | diff to current |
2010-04-14 |
Dan Gohman | Trim #includes. |
blob | commitdiff | raw | diff to current |
2010-04-05 |
Chris Lattner | remove some redundant MMI arguments. |
blob | commitdiff | raw | diff to current |
2010-04-05 |
Chris Lattner | fastisel doesn't need DwarfWriter, remove some tendricles. |
blob | commitdiff | raw | diff to current |
2010-03-28 |
Chris Lattner | add an optimized form of OPC_EmitMergeInputChains for... |
blob | commitdiff | raw | diff to current |
2010-03-14 |
Chris Lattner | change the LabelSDNode to be EHLabelSDNode and make... |
blob | commitdiff | raw | diff to current |
2010-03-04 |
Chris Lattner | inline CannotYetSelectIntrinsic into CannotYetSelect... |
blob | commitdiff | raw | diff to current |
2010-03-03 |
Chris Lattner | speed up scope node processing: if the first element... |
blob | commitdiff | raw | diff to current |
2010-03-03 |
Chris Lattner | introduce a new SwitchTypeMatcher node (which is analog... |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | remove 300 lines of code that is now dead in the MSP430... |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | Fix some issues in WalkChainUsers dealing with |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | Fix the xfail I added a couple of patches back. The... |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | factor node morphing out to its own helper method. |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | Sink InstructionSelect() out of each target into SDISel... |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | move some code out of DAGISelHeader up to SelectionDAGI... |
blob | commitdiff | raw | diff to current |
2010-03-02 |
Chris Lattner | Rewrite chain handling validation and input TokenFactor... |
blob | commitdiff | raw | diff to current |
2010-03-01 |
Chris Lattner | Accelerate isel dispatch for tables that start with... |
blob | commitdiff | raw | diff to current |
2010-03-01 |
Chris Lattner | eliminate the CheckMultiOpcodeMatcher code and have... |
blob | commitdiff | raw | diff to current |
2010-03-01 |
Chris Lattner | add a new OPC_SwitchOpcode which is semantically equivalent |
blob | commitdiff | raw | diff to current |
2010-02-28 |
Chris Lattner | hoist the new isel interpreter out of DAGISelHeader.h |
blob | commitdiff | raw | diff to current |
2010-02-28 |
Chris Lattner | change a few opcodes to use VBRs instead of embedding |
blob | commitdiff | raw | diff to current |
2010-02-28 |
Chris Lattner | move all the opcodes out of DAGISelHeader.h (which... |
blob | commitdiff | raw | diff to current |
2010-02-22 |
Dan Gohman | Fix various doxygen warnings. |
blob | commitdiff | raw | diff to current |
2010-02-21 |
Chris Lattner | add a hook so that the new isel can run SDNodeXForms. |
blob | commitdiff | raw | diff to current |
2010-02-17 |
Chris Lattner | make the new isel's interpreter loop call the generated |
blob | commitdiff | raw | diff to current |
2010-02-16 |
Chris Lattner | generate code for node and pattern predicates. Note... |
blob | commitdiff | raw | diff to current |
2010-02-15 |
Evan Cheng | Split SelectionDAGISel::IsLegalAndProfitableToFold to |
blob | commitdiff | raw | diff to current |
2010-01-06 |
Evan Cheng | Teach dag combine to fold the following transformation... |
blob | commitdiff | raw | diff to current |
2010-01-05 |
Dan Gohman | Change SelectCode's argument from SDValue to SDNode... |
blob | commitdiff | raw | diff to current |
2009-12-05 |
Dan Gohman | Remove old DBG_LABEL code. |
blob | commitdiff | raw | diff to current |
2009-11-23 |
Dan Gohman | Rename SelectionDAGLowering to SelectionDAGBuilder... |
blob | commitdiff | raw | diff to current |
2009-11-20 |
Dan Gohman | Fix fast-isel to avoid selecting the return instruction... |
blob | commitdiff | raw | diff to current |
2009-10-29 |
Dan Gohman | Move some code from being emitted as boilerplate duplic... |
blob | commitdiff | raw | diff to current |
2009-08-10 |
Owen Anderson | Rename MVT to EVT, in preparation for splitting SimpleV... |
blob | commitdiff | raw | diff to current |
2009-07-31 |
Dan Gohman | Reapply r77654 with a fix: MachineFunctionPass's getAna... |
blob | commitdiff | raw | diff to current |
2009-07-31 |
Daniel Dunbar | Revert r77654, it appears to be causing llvm-gcc bootst... |
blob | commitdiff | raw | diff to current |
2009-07-31 |
Dan Gohman | Manage MachineFunctions with an analysis Pass instead... |
blob | commitdiff | raw | diff to current |
2009-07-08 |
Torok Edwin | Implement changes from Chris's feedback. |
blob | commitdiff | raw | diff to current |
2009-07-08 |
Torok Edwin | Convert more abort() calls to llvm_report_error(). |
blob | commitdiff | raw | diff to current |
2009-05-08 |
Anton Korobeynikov | Factor out cycle-finder code and make it generic. |
blob | commitdiff | raw | diff to current |
2009-04-29 |
Bill Wendling | Instead of passing in an unsigned value for the optimiz... |
blob | commitdiff | raw | diff to current |
2009-04-29 |
Bill Wendling | Second attempt: |
blob | commitdiff | raw | diff to current |
2009-04-28 |
Bill Wendling | r70270 isn't ready yet. Back this out. Sorry for the... |
blob | commitdiff | raw | diff to current |
2009-04-28 |
Bill Wendling | Massive check in. This changes the "-fast" flag to... |
blob | commitdiff | raw | diff to current |
2009-02-11 |
Dan Gohman | When scheduling a block in parts, keep track of the... |
blob | commitdiff | raw | diff to current |
2009-02-06 |
Dan Gohman | Rename SelectionDAGISel::Schedule to |
blob | commitdiff | raw | diff to current |
2009-01-15 |
Dan Gohman | Generalize the HazardRecognizer interface so that it... |
blob | commitdiff | raw | diff to current |
2009-01-15 |
Dan Gohman | Move a few containers out of ScheduleDAGInstrs::BuildSc... |
blob | commitdiff | raw | diff to current |
2009-01-13 |
Devang Patel | Use DebugInfo interface to lower dbg_* intrinsics. |
blob | commitdiff | raw | diff to current |
2008-11-27 |
Evan Cheng | On x86 favors folding short immediate into some arithme... |
blob | commitdiff | raw | diff to current |
2008-11-12 |
Dan Gohman | Move the code that inserts X87 FP_REG_KILL instructions... |
blob | commitdiff | raw | diff to current |
2008-10-14 |
Dan Gohman | FastISel support for exception-handling constructs. |
blob | commitdiff | raw | diff to current |
2008-09-30 |
Dan Gohman | Optimize SelectionDAG's AssignTopologicalOrder even... |
blob | commitdiff | raw | diff to current |
2008-09-23 |
Dan Gohman | Arrange for FastISel code to have access to the Machine... |
blob | commitdiff | raw | diff to current |
2008-09-03 |
Dan Gohman | Create HandlePHINodesInSuccessorBlocksFast, a version of |
blob | commitdiff | raw | diff to current |
2008-08-28 |
Dan Gohman | Fix a FastISel bug where the instructions from lowering... |
blob | commitdiff | raw | diff to current |
2008-08-27 |
Dan Gohman | Reorganize the lifetimes of the major objects Selection... |
blob | commitdiff | raw | diff to current |
2008-08-23 |
Dan Gohman | Move the point at which FastISel taps into the Selectio... |
blob | commitdiff | raw | diff to current |
2008-08-21 |
Dan Gohman | SelectionDAGISel::SelectRootInit does not need to be... |
blob | commitdiff | raw | diff to current |
2008-08-17 |
Gordon Henriksen | Rename some GC classes so that their roll will hopefull... |
blob | commitdiff | raw | diff to current |
2008-08-13 |
Dan Gohman | Rename SelectionDAGISel's FastISel to Fast, to begin... |
blob | commitdiff | raw | diff to current |
2008-08-07 |
Evan Cheng | Factor code that finalize PHI nodes, jump tables, etc... |
blob | commitdiff | raw | diff to current |
2008-07-28 |
Dan Gohman | Fold the useful features of alist and alist_node into... |
blob | commitdiff | raw | diff to current |
2008-07-27 |
Dan Gohman | Rename SDOperand to SDValue. |
blob | commitdiff | raw | diff to current |
2008-07-21 |
Dan Gohman | Add titles to the various SelectionDAG viewGraph calls |
blob | commitdiff | raw | diff to current |
2008-07-14 |
Dan Gohman | Reapply 53476 and 53480, with a fix so that it properly... |
blob | commitdiff | raw | diff to current |
2008-07-12 |
Evan Cheng | Back out 53476 and 53480 for now. Somehow they cause... |
blob | commitdiff | raw | diff to current |
2008-07-11 |
Dan Gohman | Add support for putting NamedRegionTimers in TimerGroup... |
blob | commitdiff | raw | diff to current |
2008-07-11 |
Dan Gohman | Trim unnecessary #includes. |
blob | commitdiff | raw | diff to current |
next |