2011-04-15 |
Chris Lattner | Fix a ton of comment typos found by codespell. Patch by |
blob | commitdiff | raw |
2011-03-27 |
Frits van Bommel | Constant folding support for calls to umul.with.overflo... |
blob | commitdiff | raw | diff to current |
2011-03-17 |
Benjamin Kramer | Add an argument to APInt's magic udiv calculation to... |
blob | commitdiff | raw | diff to current |
2011-02-21 |
Cameron Zwarich | The signed version of our "magic number" computation... |
blob | commitdiff | raw | diff to current |
2010-12-07 |
Jay Foad | PR5207: Change APInt methods trunc(), sext(), zext... |
blob | commitdiff | raw | diff to current |
2010-12-04 |
Benjamin Kramer | APInt: microoptimize a few methods. |
blob | commitdiff | raw | diff to current |
2010-12-01 |
Jay Foad | PR5207: Rename overloaded APInt methods set(), clear... |
blob | commitdiff | raw | diff to current |
2010-11-30 |
Jay Foad | PR5207: Make APInt::set(), APInt::clear() and APInt... |
blob | commitdiff | raw | diff to current |
2010-11-18 |
Dan Gohman | Bounds-check APInt's operator[]. |
blob | commitdiff | raw | diff to current |
2010-10-14 |
Chris Lattner | fix a bug I introduced, no idea how this didn't repro... |
blob | commitdiff | raw | diff to current |
2010-10-14 |
Chris Lattner | add uadd_ov/usub_ov to apint, consolidate constant... |
blob | commitdiff | raw | diff to current |
2010-10-13 |
Chris Lattner | constify these methods. |
blob | commitdiff | raw | diff to current |
2010-10-13 |
Chris Lattner | add a few operations for signed operations that also |
blob | commitdiff | raw | diff to current |
2010-08-18 |
Chris Lattner | stomp some more undefined behavior, PR7775. |
blob | commitdiff | raw | diff to current |
2010-07-14 |
Benjamin Kramer | Don't pass StringRef by reference. |
blob | commitdiff | raw | diff to current |
2010-05-15 |
Chris Lattner | improve portability to systems that don't have round... |
blob | commitdiff | raw | diff to current |
2010-03-26 |
Chris Lattner | improve portability to minix, patch by |
blob | commitdiff | raw | diff to current |
2010-03-24 |
Dan Gohman | Fix minor style issues. |
blob | commitdiff | raw | diff to current |
2010-02-28 |
John McCall | Teach APFloat how to create both QNaNs and SNaNs and... |
blob | commitdiff | raw | diff to current |
2010-02-10 |
Dan Gohman | Fix "the the" and similar typos. |
blob | commitdiff | raw | diff to current |
2010-02-03 |
John McCall | Make APInt::countLeadingZerosSlowCase() treat the conte... |
blob | commitdiff | raw | diff to current |
2010-01-05 |
David Greene | Change errs() to dbgs(). |
blob | commitdiff | raw | diff to current |
2009-12-24 |
John McCall | Set Remainder before Quotient in case Quotient and... |
blob | commitdiff | raw | diff to current |
2009-09-20 |
Daniel Dunbar | Tabs -> spaces, and remove trailing whitespace. |
blob | commitdiff | raw | diff to current |
2009-09-06 |
Duncan Sands | Remove some unused variables and methods warned about by |
blob | commitdiff | raw | diff to current |
2009-08-23 |
Chris Lattner | remove the dead std::ostream APInt inserter |
blob | commitdiff | raw | diff to current |
2009-08-21 |
Erick Tryzelaar | Clean up the APInt function getDigit. |
blob | commitdiff | raw | diff to current |
2009-08-21 |
Eric Christopher | Update error messages for '+'. Fix grammar and make... |
blob | commitdiff | raw | diff to current |
2009-08-21 |
Eric Christopher | Fix trailing whitespace and 80-col violation. |
blob | commitdiff | raw | diff to current |
2009-08-21 |
Erick Tryzelaar | Fix bug with APInt::getBitsNeeded with for base 10... |
blob | commitdiff | raw | diff to current |
2009-08-21 |
Erick Tryzelaar | Allow '+' to appear in APInt strings, and add more... |
blob | commitdiff | raw | diff to current |
2009-08-19 |
Daniel Dunbar | Switch to SmallString::str from SmallString::c_str... |
blob | commitdiff | raw | diff to current |
2009-08-13 |
Daniel Dunbar | Convert APint::{fromString,APInt,getBitsNeeded} to... |
blob | commitdiff | raw | diff to current |
2009-08-12 |
Dale Johannesen | Add attempted idiotproofing comment per review. |
blob | commitdiff | raw | diff to current |
2009-08-12 |
Dale Johannesen | Fix a nondeterministic bug in APInt::roundToDouble; |
blob | commitdiff | raw | diff to current |
2009-07-14 |
Torok Edwin | llvm_unreachable->llvm_unreachable(0), LLVM_UNREACHABLE... |
blob | commitdiff | raw | diff to current |
2009-07-13 |
Daniel Dunbar | Switch to raw_ostream. |
blob | commitdiff | raw | diff to current |
2009-07-11 |
Torok Edwin | assert(0) -> LLVM_UNREACHABLE. |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Dan Gohman | Reapply 74494, this time removing the conflicting defin... |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Bill Wendling | Temporarily revert r74494. It was causing failures... |
blob | commitdiff | raw | diff to current |
2009-06-30 |
Dan Gohman | Define an operator<< for APInt to be used with std... |
blob | commitdiff | raw | diff to current |
2009-05-21 |
Evan Cheng | 80 column violation. |
blob | commitdiff | raw | diff to current |
2009-05-13 |
Mike Stump | Fix whitespacing (space after switch). |
blob | commitdiff | raw | diff to current |
2009-04-30 |
Jay Foad | Move helper functions for optimizing division by consta... |
blob | commitdiff | raw | diff to current |
2009-04-25 |
Chris Lattner | Fix PR4040: APInt's string constructor is too strict |
blob | commitdiff | raw | diff to current |
2009-04-01 |
Dan Gohman | Use CHAR_BIT instead of hard-coding 8 in several places... |
blob | commitdiff | raw | diff to current |
2009-03-19 |
Duncan Sands | Fix comment typo. |
blob | commitdiff | raw | diff to current |
2009-03-13 |
Stuart Hastings | Fix a hashing bug in APInt. A certain pathological... |
blob | commitdiff | raw | diff to current |
2009-01-27 |
Torok Edwin | APInt's countLeadingOnes() was broken for negative... |
blob | commitdiff | raw | diff to current |
2009-01-21 |
Chris Lattner | Remove uses of uint32_t in favor of 'unsigned' for... |
blob | commitdiff | raw | diff to current |
2009-01-19 |
Nick Lewycky | Fix typo, sentence fragment. |
blob | commitdiff | raw | diff to current |
2008-10-11 |
Chris Lattner | rearrange some code. |
blob | commitdiff | raw | diff to current |
2008-08-23 |
Chris Lattner | Switch the asmprinter (.ll) and all the stuff it requir... |
blob | commitdiff | raw | diff to current |
2008-08-20 |
Chris Lattner | Move the fast-path (<=i64) cases of various APInt metho... |
blob | commitdiff | raw | diff to current |
2008-08-20 |
Dan Gohman | It's not necessary to check if a value is null before... |
blob | commitdiff | raw | diff to current |
2008-08-17 |
Chris Lattner | Rework the routines that convert AP[S]Int into a string... |
blob | commitdiff | raw | diff to current |
2008-08-17 |
Chris Lattner | remove a dead APInt ctor. |
blob | commitdiff | raw | diff to current |
2008-07-20 |
Wojciech Matyjewicz | Fix PR2088. Use modulo linear equation solver to comput... |
blob | commitdiff | raw | diff to current |
2008-06-23 |
Wojciech Matyjewicz | First step to fix PR2088. Implement routine to compute the |
blob | commitdiff | raw | diff to current |
2008-06-21 |
Dan Gohman | Avoid creating a redundant zero APInt. |
blob | commitdiff | raw | diff to current |
2008-06-05 |
Zhou Sheng | As comments said, for negative value, the arithmetic |
blob | commitdiff | raw | diff to current |
2008-05-02 |
Evan Cheng | Suppress -Wshorten-64-to-32 warnings for 64-bit hosts. |
blob | commitdiff | raw | diff to current |
2008-04-10 |
Dan Gohman | Make several symbols static. |
blob | commitdiff | raw | diff to current |
2008-03-25 |
Dan Gohman | A quick nm audit turned up several fixed tables and... |
blob | commitdiff | raw | diff to current |
2008-03-16 |
Bill Wendling | Add assert for non-hexadecimal radixes. |
blob | commitdiff | raw | diff to current |
2008-03-07 |
Evan Cheng | Fix a typo. It's causing consumer-typeset to miscompile... |
blob | commitdiff | raw | diff to current |
2008-02-29 |
Dan Gohman | Add support to APInt for shift and rotate operations... |
blob | commitdiff | raw | diff to current |
2008-02-19 |
Ted Kremenek | Fixed bug in APInt::Profile() where the BitWidth field... |
blob | commitdiff | raw | diff to current |
2008-02-14 |
Dan Gohman | Fix a warning about comparison between signed and unsigned, |
blob | commitdiff | raw | diff to current |
2008-02-13 |
Dan Gohman | Add countTrailingOnes member functions to APInt. |
blob | commitdiff | raw | diff to current |
2008-01-19 |
Ted Kremenek | Added FoldingSet style 'profiling' support for APInt. |
blob | commitdiff | raw | diff to current |
2007-12-29 |
Chris Lattner | Remove attribution from file headers, per discussion... |
blob | commitdiff | raw | diff to current |
2007-12-24 |
Anton Korobeynikov | Cygwin defines uint32_t as unsigned long. Unbreak call... |
blob | commitdiff | raw | diff to current |
2007-12-11 |
Reid Spencer | Don't have APInt.cpp depend upon DerivedTypes.h. This... |
blob | commitdiff | raw | diff to current |
2007-11-23 |
Chris Lattner | Fix PR1816, by correcting the broken definition of... |
blob | commitdiff | raw | diff to current |
2007-11-23 |
Chris Lattner | Fix APInt::countTrailingZeros to return BitWidth if... |
blob | commitdiff | raw | diff to current |
2007-10-12 |
Neil Booth | Don't attempt to mask no bits |
blob | commitdiff | raw | diff to current |
2007-10-08 |
Neil Booth | Add a new function tcExtract for extracting a bignum... |
blob | commitdiff | raw | diff to current |
2007-10-06 |
Neil Booth | Fix and clarify some comments. |
blob | commitdiff | raw | diff to current |
2007-10-06 |
Neil Booth | Generalize tcFullMultiply so that the operands can... |
blob | commitdiff | raw | diff to current |
2007-09-21 |
Dale Johannesen | Change APFloat::convertFromInteger to take the incoming |
blob | commitdiff | raw | diff to current |
2007-09-17 |
Devang Patel | Do not hide APInt::dump() inside #ifndef NDEBUG. |
blob | commitdiff | raw | diff to current |
2007-09-14 |
Dale Johannesen | Remove the assumption that FP's are either float or |
blob | commitdiff | raw | diff to current |
2007-08-23 |
Chris Lattner | rename APInt::toString -> toStringUnsigned for symmetry... |
blob | commitdiff | raw | diff to current |
2007-08-20 |
Chris Lattner | initial checkin of Neil's APFloat work. |
blob | commitdiff | raw | diff to current |
2007-08-16 |
Chris Lattner | This adds a bunch of static functions that implement... |
blob | commitdiff | raw | diff to current |
2007-05-19 |
Reid Spencer | Fix an assertion introduced by my last change to the... |
blob | commitdiff | raw | diff to current |
2007-05-17 |
Reid Spencer | Get rid of leading zeros in the output of toString. |
blob | commitdiff | raw | diff to current |
2007-05-17 |
Reid Spencer | For lshr by 0 bits, just return *this as a short cut... |
blob | commitdiff | raw | diff to current |
2007-05-16 |
Reid Spencer | Fix a bug in the "fromString" method where radix 2... |
blob | commitdiff | raw | diff to current |
2007-05-14 |
Reid Spencer | Make the results for the rotate functions correct when... |
blob | commitdiff | raw | diff to current |
2007-05-13 |
Reid Spencer | Add some things needed by the llvm-gcc version supporti... |
blob | commitdiff | raw | diff to current |
2007-05-12 |
Reid Spencer | Fix shl to produce the correct result when the bitwidth... |
blob | commitdiff | raw | diff to current |
2007-05-03 |
Chris Lattner | silence some annoying gcc 4.3 warnings |
blob | commitdiff | raw | diff to current |
2007-04-14 |
Reid Spencer | We want the number of bits needed, not the power of 2. |
blob | commitdiff | raw | diff to current |
2007-04-13 |
Reid Spencer | Implement a getBitsNeeded method to determine how many... |
blob | commitdiff | raw | diff to current |
2007-04-11 |
Reid Spencer | Fix an approximate calculation in an assertion not... |
blob | commitdiff | raw | diff to current |
2007-03-21 |
Zhou Sheng | Fix a bug in getAllOnesValue() which broke |
blob | commitdiff | raw | diff to current |
2007-03-20 |
Jeff Cohen | Fix (and simplify) 48-bit byte swap. |
blob | commitdiff | raw | diff to current |
2007-03-19 |
Reid Spencer | Fix coding standards violation. |
blob | commitdiff | raw | diff to current |
next |