2009-06-19 |
Dan Gohman | Fix LSR's OptimizeSMax to ignore max operators with... |
blob | commitdiff | raw |
2009-06-19 |
Evan Cheng | Revert 73718. It's breaking 254.gap. |
blob | commitdiff | raw | diff to current |
2009-06-18 |
Dan Gohman | Generalize LSR's OptimizeSMax to handle unsigned max... |
blob | commitdiff | raw | diff to current |
2009-06-18 |
Dan Gohman | Remove the code from IVUsers that attempted to handle |
blob | commitdiff | raw | diff to current |
2009-06-17 |
Dan Gohman | Update comments to use doxygen syntax. |
blob | commitdiff | raw | diff to current |
2009-06-15 |
Dan Gohman | Support vector casts in more places, fixing a variety... |
blob | commitdiff | raw | diff to current |
2009-06-14 |
Dan Gohman | Convert several parts of the ScalarEvolution framework... |
blob | commitdiff | raw | diff to current |
2009-06-05 |
Devang Patel | Simplify. |
blob | commitdiff | raw | diff to current |
2009-06-04 |
Dan Gohman | Split the Add, Sub, and Mul instruction opcodes into... |
blob | commitdiff | raw | diff to current |
2009-05-27 |
Dan Gohman | Revert 72493 and replace it with a more conservative... |
blob | commitdiff | raw | diff to current |
2009-05-27 |
Dan Gohman | In ChangeCompareStride, when the stride to be reused... |
blob | commitdiff | raw | diff to current |
2009-05-20 |
Dan Gohman | Suppress the IV reversal transformation in the case... |
blob | commitdiff | raw | diff to current |
2009-05-19 |
Dan Gohman | Add some more comments to the top of this file. |
blob | commitdiff | raw | diff to current |
2009-05-19 |
Dan Gohman | Trim unneeded #includes. |
blob | commitdiff | raw | diff to current |
2009-05-19 |
Dan Gohman | Teach SCEVExpander to expand arithmetic involving point... |
blob | commitdiff | raw | diff to current |
2009-05-18 |
Dan Gohman | Rename UseTy to AccessTy, for consistency with getAcces... |
blob | commitdiff | raw | diff to current |
2009-05-13 |
Dale Johannesen | Add an int64_t variant of abs, for host environments |
blob | commitdiff | raw | diff to current |
2009-05-12 |
Dan Gohman | Factor the code for collecting IV users out of LSR... |
blob | commitdiff | raw | diff to current |
2009-05-11 |
Evan Cheng | Teach LSR to optimize more loop exit compares, i.e... |
blob | commitdiff | raw | diff to current |
2009-05-11 |
Dale Johannesen | Reverse a loop that is counting up to a maximum to |
blob | commitdiff | raw | diff to current |
2009-05-09 |
Evan Cheng | Factor out code that optimize loop terminating condition. |
blob | commitdiff | raw | diff to current |
2009-05-06 |
Evan Cheng | Unbreak the build. |
blob | commitdiff | raw | diff to current |
2009-05-06 |
David Greene | Make sure to use signed arithmetic in APInt to fix... |
blob | commitdiff | raw | diff to current |
2009-05-05 |
Dan Gohman | Fix a copy+pasto in a comment. |
blob | commitdiff | raw | diff to current |
2009-05-05 |
Dan Gohman | Delete a FIXME which is no longer relevant, and add... |
blob | commitdiff | raw | diff to current |
2009-05-05 |
Bill Wendling | Temporarily reverting r71008. It was causing this failure: |
blob | commitdiff | raw | diff to current |
2009-05-05 |
David Greene | Handle overflow of 64-bit loop conditions. |
blob | commitdiff | raw | diff to current |
2009-05-04 |
Dan Gohman | Re-apply 70645, converting ScalarEvolution to use |
blob | commitdiff | raw | diff to current |
2009-05-04 |
Dan Gohman | Constify a bunch of SCEV-using code. |
blob | commitdiff | raw | diff to current |
2009-05-03 |
Dan Gohman | Revert r70645 for now; it's causing a variety of regres... |
blob | commitdiff | raw | diff to current |
2009-05-02 |
Dan Gohman | Convert ScalarEvolution to use CallbackVH for its inter... |
blob | commitdiff | raw | diff to current |
2009-05-02 |
Dan Gohman | Previously, RecursivelyDeleteDeadInstructions provided... |
blob | commitdiff | raw | diff to current |
2009-05-02 |
Dan Gohman | Don't split critical edges during the AddUsersIfInteres... |
blob | commitdiff | raw | diff to current |
2009-05-01 |
Dan Gohman | Make RequiresTypeConversion canonicalize the types... |
blob | commitdiff | raw | diff to current |
2009-05-01 |
Dan Gohman | Minor whitespace fix. |
blob | commitdiff | raw | diff to current |
2009-05-01 |
Dan Gohman | Fix some code to work if TargetLowering is not available. |
blob | commitdiff | raw | diff to current |
2009-04-29 |
Dale Johannesen | Print correct instruction in dump. |
blob | commitdiff | raw | diff to current |
2009-04-27 |
Dan Gohman | Permit ChangeCompareStride to rewrite a comparison... |
blob | commitdiff | raw | diff to current |
2009-04-21 |
Dan Gohman | Factor out a common base class from SCEVTruncateExpr... |
blob | commitdiff | raw | diff to current |
2009-04-21 |
Dan Gohman | Introduce encapsulation for ScalarEvolution's TargetDat... |
blob | commitdiff | raw | diff to current |
2009-04-18 |
Dan Gohman | Use more const qualifiers with SCEV interfaces. |
blob | commitdiff | raw | diff to current |
2009-04-17 |
Dan Gohman | Don't create ConstantInts with pointer type. This fixes a |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | Use TargetData::getTypeSizeInBits instead of getPrimiti... |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | Minor code simplifications. Don't attempt LSR on theore... |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | LSR is no longer a GEP optimizer. It is now an IV expre... |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | Use ConstantExpr::getIntToPtr instead of SCEVExpander... |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | Use a SCEV expression cast instead of immediately inser... |
blob | commitdiff | raw | diff to current |
2009-04-16 |
Dan Gohman | Expand GEPs in ScalarEvolution expressions. SCEV expres... |
blob | commitdiff | raw | diff to current |
2009-03-17 |
Chris Lattner | LSR shouldn't ever try to hack on integer IV's larger... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Don't record the increment instruction; just recompute... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Fix a few more places where induction variable types... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Use ReplacedTy instead of recomputing the same value. |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Use LoopInfo's getLoopLatch() instead of doing what... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Don't use an induction variable type as a memory access... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Factor out the code that determines the memory access... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Move the sorting of the StrideOrder array earlier so... |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Delete the isOnlyStride argument, which is unused. |
blob | commitdiff | raw | diff to current |
2009-03-09 |
Dan Gohman | Tidy some LSR debug output: announce the loop it's... |
blob | commitdiff | raw | diff to current |
2009-03-04 |
Dan Gohman | Fix this comment. |
blob | commitdiff | raw | diff to current |
2009-03-04 |
Dan Gohman | Add an assertion for a condition that's always true... |
blob | commitdiff | raw | diff to current |
2009-02-24 |
Dan Gohman | Rename ScalarEvolution's getIterationCount to getBacked... |
blob | commitdiff | raw | diff to current |
2009-02-24 |
Dan Gohman | Generalize the ChangeCompareStride code, in preparation for |
blob | commitdiff | raw | diff to current |
2009-02-22 |
Dan Gohman | Properly parenthesize this expression, fixing a real... |
blob | commitdiff | raw | diff to current |
2009-02-22 |
Evan Cheng | Only try to sink immediate when TLI is not null. It... |
blob | commitdiff | raw | diff to current |
2009-02-21 |
Evan Cheng | Teach LSR sink to sink the immediate portion of the... |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Evan Cheng | Fix strange logic in CollectIVUsers used to determine... |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Dan Gohman | Simplify code and reduce indentation. No functionality... |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Dan Gohman | Fix 80-column violations. |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Dan Gohman | It's not necessary to check if Base is null here. |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Dan Gohman | Add a comment about how Imm can be used for loop-varian... |
blob | commitdiff | raw | diff to current |
2009-02-20 |
Dan Gohman | Implement "superhero" strength reduction, or full strength |
blob | commitdiff | raw | diff to current |
2009-02-19 |
Dan Gohman | Use DEBUG() instead of passing *DOUT to WriteAsOperand, |
blob | commitdiff | raw | diff to current |
2009-02-19 |
Dan Gohman | Make the debug output of LSR less cryptic and more... |
blob | commitdiff | raw | diff to current |
2009-02-18 |
Dan Gohman | Fix a typo in a comment. |
blob | commitdiff | raw | diff to current |
2009-02-17 |
Evan Cheng | Strengthen the "non-constant stride must dominate loop... |
blob | commitdiff | raw | diff to current |
2009-02-15 |
Evan Cheng | Fix pr3571: If stride is a value defined by an instruct... |
blob | commitdiff | raw | diff to current |
2009-02-15 |
Evan Cheng | ifdef out unneeded if statement. |
blob | commitdiff | raw | diff to current |
2009-02-13 |
Dan Gohman | Complete the sentance in this comment. I have reservations |
blob | commitdiff | raw | diff to current |
2009-02-13 |
Dan Gohman | Fix the code that checked if a SCEVAddRecExpr Start... |
blob | commitdiff | raw | diff to current |
2009-02-13 |
Dan Gohman | Fix LSR's IV sorting function to explicitly sort by... |
blob | commitdiff | raw | diff to current |
2009-02-09 |
Dale Johannesen | Fix PR 3471, and some cleanups. |
blob | commitdiff | raw | diff to current |
2009-01-14 |
Dale Johannesen | Fix the time regression I introduced in 464.h264ref... |
blob | commitdiff | raw | diff to current |
2009-01-12 |
Duncan Sands | Rename getABITypeSize to getTypePaddedSize, as |
blob | commitdiff | raw | diff to current |
2008-12-23 |
Dale Johannesen | Revert 61362 and 61402 until SPEC breakage is fixed. |
blob | commitdiff | raw | diff to current |
2008-12-23 |
Dale Johannesen | This fixes the bug in 175.vpr. It doesn't fix the |
blob | commitdiff | raw | diff to current |
2008-12-23 |
Dale Johannesen | Fix the time regression I introduced in 464.h264ref... |
blob | commitdiff | raw | diff to current |
2008-12-18 |
Dale Johannesen | Revert previous patch, appears to break bootstrap. |
blob | commitdiff | raw | diff to current |
2008-12-18 |
Dale Johannesen | Fix the time regression I introduced in 464.h264ref... |
blob | commitdiff | raw | diff to current |
2008-12-16 |
Dale Johannesen | Clarify that the scale factor from CheckForIVReuse |
blob | commitdiff | raw | diff to current |
2008-12-09 |
Chris Lattner | Fix a really subtle off-by-one bug that Duncan noticed... |
blob | commitdiff | raw | diff to current |
2008-12-05 |
Dale Johannesen | Make LoopStrengthReduce smarter about hoisting things... |
blob | commitdiff | raw | diff to current |
2008-12-03 |
Dale Johannesen | Remove an unused field. |
blob | commitdiff | raw | diff to current |
2008-12-03 |
Dale Johannesen | Fix a misspelled function name. |
blob | commitdiff | raw | diff to current |
2008-12-03 |
Dale Johannesen | Fix a really wrong comment. |
blob | commitdiff | raw | diff to current |
2008-12-02 |
Dale Johannesen | Minor rewrite per review feedback. |
blob | commitdiff | raw | diff to current |
2008-12-02 |
Dale Johannesen | Make the code do what the comment says it does. |
blob | commitdiff | raw | diff to current |
2008-12-02 |
Chris Lattner | some random comment improvements. |
blob | commitdiff | raw | diff to current |
2008-12-01 |
Dale Johannesen | Consider only references to an IV within the loop when |
blob | commitdiff | raw | diff to current |
2008-12-01 |
Chris Lattner | Introduce a new array_pod_sort function and switch... |
blob | commitdiff | raw | diff to current |
2008-12-01 |
Chris Lattner | Eliminate use of setvector for the DeadInsts set, just... |
blob | commitdiff | raw | diff to current |
next |