Adds cmake file for junction test case
[junction.git] / test / CMakeLists.txt
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644 (file)
index 0000000..c7b7493
--- /dev/null
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8.5)
+
+set(PACKAGE_NAME stress-sequential-junction)
+set(JUNCTION_TEST_SOURCES
+    junction_driver.cpp
+)
+
+set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
+
+set(JUNCTION_LIB
+  junction
+  turf
+)
+
+add_executable(${PACKAGE_NAME} ${JUNCTION_TEST_SOURCES})
+target_link_libraries(${PACKAGE_NAME} ${JUNCTION_LIB})